aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/test/firebase/firestore/testutil/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-02-22 08:26:22 -0800
committerGravatar GitHub <noreply@github.com>2018-02-22 08:26:22 -0800
commit4dc63f8d7cbf60417b88c6a77839ea32656627b9 (patch)
tree9e06e7c40b71caea3a89813a506c9aebccdf1401 /Firestore/core/test/firebase/firestore/testutil/CMakeLists.txt
parent935f3ca7d749f96c7207236a39c57f32a02c05d3 (diff)
Fix Firestore tests for M22 (#834)
* Add FIRFirestoreTests to the Firestore Xcode project * Avoid waitForExpectations:timeout: This API was added in Xcode 8.3, but we still build production releases with Xcode 8.2. waitForExpectationsWithTimeout:handler: is available from Xcode 7.2. * Add AppForUnitTesting Add a utility for constructing a Firebase App for testing. * Handle the nil UID from FIRAuth * Avoid running CMake tests twice * Only build app_testing on Apple platforms * Revise test.sh messages
Diffstat (limited to 'Firestore/core/test/firebase/firestore/testutil/CMakeLists.txt')
-rw-r--r--Firestore/core/test/firebase/firestore/testutil/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/Firestore/core/test/firebase/firestore/testutil/CMakeLists.txt b/Firestore/core/test/firebase/firestore/testutil/CMakeLists.txt
new file mode 100644
index 0000000..b9fcd47
--- /dev/null
+++ b/Firestore/core/test/firebase/firestore/testutil/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Copyright 2018 Google
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cc_library(
+ firebase_firestore_testutil_apple
+ SOURCES
+ app_testing.h
+ app_testing.mm
+ DEPENDS
+ FirebaseCore
+ absl_strings
+)
+
+if(APPLE)
+ list(APPEND TESTUTIL_DEPENDS firebase_firestore_testutil_apple)
+endif()
+
+add_library(
+ firebase_firestore_testutil INTERFACE
+)
+target_link_libraries(
+ firebase_firestore_testutil INTERFACE
+ ${TESTUTIL_DEPENDS}
+)