aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/test/firebase/firestore/remote/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Konstantin Varlamov <var-const@users.noreply.github.com>2018-07-10 17:45:16 -0400
committerGravatar GitHub <noreply@github.com>2018-07-10 17:45:16 -0400
commit6466c35737eff21e9b48c3ce2353d42628f4bb77 (patch)
tree812f47917bbe834a9e0b490c11265930da1639c8 /Firestore/core/test/firebase/firestore/remote/CMakeLists.txt
parent0f0a1dab2d385895fc15968cfee3df07b53c52b9 (diff)
C++ migration: add a C++ implementation of `FSTExponentialBackoff` (#1465)
This is a pretty close port of `FSTExponentialBackoff`. The changes are pretty minor: * delay is calculated using <chrono> duration types, not plain numbers, which should be a little more type-safe; * split a piece of code into a ClampDelay function, because it's reasonably close to std::clamp; * rephrased the class-level comment to make it clearer that the first attempt always has delay = 0; * added simple tests (other platforms don't have tests for this). Also make sure that canceling a DelayedOperation is always valid.
Diffstat (limited to 'Firestore/core/test/firebase/firestore/remote/CMakeLists.txt')
-rw-r--r--Firestore/core/test/firebase/firestore/remote/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Firestore/core/test/firebase/firestore/remote/CMakeLists.txt b/Firestore/core/test/firebase/firestore/remote/CMakeLists.txt
index 1b4142a..d91dc0f 100644
--- a/Firestore/core/test/firebase/firestore/remote/CMakeLists.txt
+++ b/Firestore/core/test/firebase/firestore/remote/CMakeLists.txt
@@ -16,8 +16,10 @@ cc_test(
firebase_firestore_remote_test
SOURCES
datastore_test.cc
+ exponential_backoff_test.cc
serializer_test.cc
DEPENDS
+ absl_base
# NB: Order is important. We need to include the ffp_libprotobuf library
# before ff_remote, or else we'll end up with nanopb's headers earlier in
# the include path than libprotobuf's, which makes using libprotobuf in the
@@ -26,4 +28,5 @@ cc_test(
# exists in both the libprotobuf path and the nanopb path.
firebase_firestore_protos_libprotobuf
firebase_firestore_remote
+ firebase_firestore_util_executor_std
)