aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/test/firebase/firestore/model/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Konstantin Varlamov <var-const@users.noreply.github.com>2018-02-06 19:15:54 -0500
committerGravatar GitHub <noreply@github.com>2018-02-06 19:15:54 -0500
commitb31fe35eb7a1301e1e6c5d3381b9f3d8054734dd (patch)
treeb21132267305b44c619a2ba1e30f03e4fad626be /Firestore/core/test/firebase/firestore/model/CMakeLists.txt
parentaa0dba767e5757017057abc299fec0a87f313bfa (diff)
C++ port: port FSTFieldPath and FSTResourcePath to C++ (#749)
Similar to Objective-C, FieldPath and ResourcePath share most of their interface (and implementation) by deriving from BasePath (using CRTP, so that factory methods in BasePath can return an instance of the derived class).
Diffstat (limited to 'Firestore/core/test/firebase/firestore/model/CMakeLists.txt')
-rw-r--r--Firestore/core/test/firebase/firestore/model/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Firestore/core/test/firebase/firestore/model/CMakeLists.txt b/Firestore/core/test/firebase/firestore/model/CMakeLists.txt
index 0f83bf2..63ed813 100644
--- a/Firestore/core/test/firebase/firestore/model/CMakeLists.txt
+++ b/Firestore/core/test/firebase/firestore/model/CMakeLists.txt
@@ -16,8 +16,10 @@ cc_test(
firebase_firestore_model_test
SOURCES
database_id_test.cc
+ field_path_test.cc
field_value_test.cc
timestamp_test.cc
+ resource_path_test.cc
DEPENDS
firebase_firestore_model
)