aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/test/firebase/firestore/immutable/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-01-31 14:28:20 -0800
committerGravatar GitHub <noreply@github.com>2018-01-31 14:28:20 -0800
commitac3052223465ce654457fec17b34f27de1706e57 (patch)
tree64acd16a6d963ba8a429ed6025e64c2e8221f411 /Firestore/core/test/firebase/firestore/immutable/CMakeLists.txt
parent729b8d176c75ecc0cbbd137cc6811116a64e310a (diff)
Start on ArraySortedMap in C++ (#721)
* Implement ArraySortedMap.remove * Implement ArraySortedMap.insert * Ensure ArraySortedMap.insert avoids copying on duplicates * Port more ArraySortedMapTests
Diffstat (limited to 'Firestore/core/test/firebase/firestore/immutable/CMakeLists.txt')
-rw-r--r--Firestore/core/test/firebase/firestore/immutable/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/Firestore/core/test/firebase/firestore/immutable/CMakeLists.txt b/Firestore/core/test/firebase/firestore/immutable/CMakeLists.txt
new file mode 100644
index 0000000..e7b0b6e
--- /dev/null
+++ b/Firestore/core/test/firebase/firestore/immutable/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Copyright 2018 Google
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cc_test(
+ firebase_firestore_immutable_test
+ SOURCES
+ array_sorted_map_test.cc
+ DEPENDS
+ firebase_firestore_immutable
+ firebase_firestore_util
+)