aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/test/firebase/firestore/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Konstantin Varlamov <var-const@users.noreply.github.com>2018-03-27 11:50:03 -0400
committerGravatar GitHub <noreply@github.com>2018-03-27 11:50:03 -0400
commit22c226af3f5570514d3d13d82a399577ecd7d280 (patch)
treefc8f3e1ca146297f2993f8391ed3dab9e0f2c153 /Firestore/core/test/firebase/firestore/CMakeLists.txt
parent13aa61633f5a98c8dd0a508e5a404017bc79370e (diff)
C++ migration: make Timestamp class a part of public API (#944)
* move Timestamp from model/ to the root directory; * move Timestamp to top-level firebase namespace and update all references; * add conversions to and from native date types; * add a specialization of std::hash; * add comments to public member functions; * rename nanos -> nanoseconds; * add public headers, including Timestamp, to CMake; * increase test coverage.
Diffstat (limited to 'Firestore/core/test/firebase/firestore/CMakeLists.txt')
-rw-r--r--Firestore/core/test/firebase/firestore/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Firestore/core/test/firebase/firestore/CMakeLists.txt b/Firestore/core/test/firebase/firestore/CMakeLists.txt
index ed5760f..61692de 100644
--- a/Firestore/core/test/firebase/firestore/CMakeLists.txt
+++ b/Firestore/core/test/firebase/firestore/CMakeLists.txt
@@ -16,6 +16,7 @@ cc_test(
firebase_firestore_types_test
SOURCES
geo_point_test.cc
+ timestamp_test.cc
DEPENDS
firebase_firestore_types
)