aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/src/firebase/firestore/util/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-06-12 09:36:08 -0700
committerGravatar GitHub <noreply@github.com>2018-06-12 09:36:08 -0700
commit9e14b80e0716c2be71c6100cad7aa7c61ac46c6e (patch)
tree09d4d4583571b56feb89f809a24626cef14a3356 /Firestore/core/src/firebase/firestore/util/CMakeLists.txt
parentf5bf0a37a7dd40e7538a1aed77af05471b7fe713 (diff)
Create Status objects from errno (#1374)
* Add a portable interface to strerror * Add Status::FromErrno * Add strerror_test.cc to the Xcode project * Use glibc feature selection macros instead of return-type overloads * Fix tensorflow references
Diffstat (limited to 'Firestore/core/src/firebase/firestore/util/CMakeLists.txt')
-rw-r--r--Firestore/core/src/firebase/firestore/util/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/Firestore/core/src/firebase/firestore/util/CMakeLists.txt b/Firestore/core/src/firebase/firestore/util/CMakeLists.txt
index b2c4195..5b38b2e 100644
--- a/Firestore/core/src/firebase/firestore/util/CMakeLists.txt
+++ b/Firestore/core/src/firebase/firestore/util/CMakeLists.txt
@@ -193,6 +193,8 @@ cc_library(
statusor.cc
statusor.h
statusor_internals.h
+ strerror.cc
+ strerror.h
string_util.cc
string_util.h
type_traits.h
@@ -203,3 +205,10 @@ cc_library(
${FIREBASE_FIRESTORE_UTIL_LOG}
${FIREBASE_FIRESTORE_UTIL_RANDOM}
)
+
+if(APPLE)
+ target_sources(
+ firebase_firestore_util PRIVATE
+ status_apple.mm
+ )
+endif()