aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/src/firebase/firestore/nanopb/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar rsgowman <rgowman@google.com>2018-05-11 10:27:48 -0400
committerGravatar GitHub <noreply@github.com>2018-05-11 10:27:48 -0400
commit56cfe9306ab60af2a17c26b291438a9449d30f5d (patch)
treededcb77f4b2b703e29307e942a58c91c66d0bdb9 /Firestore/core/src/firebase/firestore/nanopb/CMakeLists.txt
parentedd6f60a7385f9280c371df273703f6e104e325f (diff)
Refactor serializer (#1250)
Moved Tag, Reader, Writer from serializer.cc's anon namespace to firebase::firestore::nanopb This should be bug-for-bug compatible. No changes were made to the moved methods.
Diffstat (limited to 'Firestore/core/src/firebase/firestore/nanopb/CMakeLists.txt')
-rw-r--r--Firestore/core/src/firebase/firestore/nanopb/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/Firestore/core/src/firebase/firestore/nanopb/CMakeLists.txt b/Firestore/core/src/firebase/firestore/nanopb/CMakeLists.txt
new file mode 100644
index 0000000..82ffb65
--- /dev/null
+++ b/Firestore/core/src/firebase/firestore/nanopb/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright 2018 Google
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cc_library(
+ firebase_firestore_nanopb
+ SOURCES
+ tag.h
+ reader.h
+ reader.cc
+ writer.h
+ writer.cc
+ DEPENDS
+ firebase_firestore_util
+ firebase_firestore_protos_nanopb
+ nanopb
+)