aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/src/firebase/firestore/model/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar zxu <zxu@google.com>2018-01-17 13:18:54 -0500
committerGravatar GitHub <noreply@github.com>2018-01-17 13:18:54 -0500
commitcac2c3ff7aa7b94e3776bb1282765ca78be977ae (patch)
tree6234d9795604c8eb362659e4aef9cbd26550619c /Firestore/core/src/firebase/firestore/model/CMakeLists.txt
parent128e9cb170b28bbff0284610276b0e4e517f576e (diff)
implement FieldValue for null, boolean, and array in C++. (#637)
* implement FieldValue for null and boolean. * refactoring to use union type instead of poly * refactor using union design intead of poly * refactoring to use anonymous union and fix styles * small fix * add field_value_test to the project * fix warning of cmake and fix style
Diffstat (limited to 'Firestore/core/src/firebase/firestore/model/CMakeLists.txt')
-rw-r--r--Firestore/core/src/firebase/firestore/model/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/Firestore/core/src/firebase/firestore/model/CMakeLists.txt b/Firestore/core/src/firebase/firestore/model/CMakeLists.txt
new file mode 100644
index 0000000..1beb3bb
--- /dev/null
+++ b/Firestore/core/src/firebase/firestore/model/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Copyright 2018 Google
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_library(
+ firebase_firestore_model
+ field_value.cc
+)
+target_link_libraries(
+ firebase_firestore_model
+ firebase_firestore_util
+)