aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/src/firebase/firestore/model/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar zxu <zxu@google.com>2018-02-12 20:39:31 -0500
committerGravatar GitHub <noreply@github.com>2018-02-12 20:39:31 -0500
commit95045820a72d6d7de2274c0bd7632f11dee53ffa (patch)
tree114986ce8b3a819cd7dda48ee533900cc300ca1e /Firestore/core/src/firebase/firestore/model/CMakeLists.txt
parentadf9fb31eeef639ef23b2ff22a71adaa91a263b7 (diff)
Port Firestore Document to C++ (#777)
* implement SnapshotVersion and test * update project * implement MaybeDocument and test * move snapshot-version from core to model * fix a bug * implement Document and test * implement NoDocument * adding type tag and fix style * fix a few bugs, discovered after merging and test run. * add assert to check FieldValue type and more test for comparision. * address changes * allow moving FieldValue to construct Document. * address changes * add document tests to project * use std::less convention * make Type::Unknown static initializer
Diffstat (limited to 'Firestore/core/src/firebase/firestore/model/CMakeLists.txt')
-rw-r--r--Firestore/core/src/firebase/firestore/model/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/Firestore/core/src/firebase/firestore/model/CMakeLists.txt b/Firestore/core/src/firebase/firestore/model/CMakeLists.txt
index 95310ec..1b0e6a4 100644
--- a/Firestore/core/src/firebase/firestore/model/CMakeLists.txt
+++ b/Firestore/core/src/firebase/firestore/model/CMakeLists.txt
@@ -18,16 +18,22 @@ cc_library(
base_path.h
database_id.cc
database_id.h
+ document.cc
+ document.h
document_key.cc
document_key.h
field_path.cc
field_path.h
field_value.cc
field_value.h
- snapshot_version.cc
- snapshot_version.h
+ maybe_document.cc
+ maybe_document.h
+ no_document.cc
+ no_document.h
resource_path.cc
resource_path.h
+ snapshot_version.cc
+ snapshot_version.h
timestamp.cc
timestamp.h
DEPENDS