aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/src/firebase/firestore/local/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-03-21 18:43:29 -0700
committerGravatar GitHub <noreply@github.com>2018-03-21 18:43:29 -0700
commitcf630bfee60694f9bf1577972df169badda0b6e0 (patch)
tree2b815ec0e241666aa04da5e58e7c85ce23518e50 /Firestore/core/src/firebase/firestore/local/CMakeLists.txt
parent5f49b2f3f9866e4db13d09857eb3b548239cc62e (diff)
Port FSTLevelDBKey to C++ (#937)
Diffstat (limited to 'Firestore/core/src/firebase/firestore/local/CMakeLists.txt')
-rw-r--r--Firestore/core/src/firebase/firestore/local/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/Firestore/core/src/firebase/firestore/local/CMakeLists.txt b/Firestore/core/src/firebase/firestore/local/CMakeLists.txt
new file mode 100644
index 0000000..089d03c
--- /dev/null
+++ b/Firestore/core/src/firebase/firestore/local/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Copyright 2018 Google
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cc_library(
+ firebase_firestore_local
+ SOURCES
+ leveldb_key.h
+ leveldb_key.cc
+ DEPENDS
+ LevelDB::LevelDB
+ absl_strings
+ firebase_firestore_model
+ firebase_firestore_util
+)