aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/src/firebase/firestore/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar rsgowman <rgowman@google.com>2018-07-13 16:22:07 -0400
committerGravatar GitHub <noreply@github.com>2018-07-13 16:22:07 -0400
commit920cfbfa998ca9d04cce5f7731aced7e950a3477 (patch)
tree76f62fa05240d533477707bb4cd26df6808cd523 /Firestore/core/src/firebase/firestore/core/CMakeLists.txt
parent81ec26d4ff2f9cc295bf057167a649a34a7a11aa (diff)
Initial (incomplete) implementation of f:f:core::Filter (#1495)
And RelationFilter subclass. Used to implement the next step in core::Query.
Diffstat (limited to 'Firestore/core/src/firebase/firestore/core/CMakeLists.txt')
-rw-r--r--Firestore/core/src/firebase/firestore/core/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Firestore/core/src/firebase/firestore/core/CMakeLists.txt b/Firestore/core/src/firebase/firestore/core/CMakeLists.txt
index 1aab09a..c1557b2 100644
--- a/Firestore/core/src/firebase/firestore/core/CMakeLists.txt
+++ b/Firestore/core/src/firebase/firestore/core/CMakeLists.txt
@@ -17,10 +17,14 @@ cc_library(
SOURCES
database_info.cc
database_info.h
+ filter.cc
+ filter.h
target_id_generator.cc
target_id_generator.h
query.cc
query.h
+ relation_filter.cc
+ relation_filter.h
DEPENDS
absl_strings
firebase_firestore_model