aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/src/firebase/firestore/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar zxu <zxu@google.com>2018-01-25 13:05:30 -0500
committerGravatar GitHub <noreply@github.com>2018-01-25 13:05:30 -0500
commit821fb909a3007f697ad96d83c6b8e8cc70df0b6b (patch)
tree10189661f3d1cfa149d97c2a3fef1ed2f393d091 /Firestore/core/src/firebase/firestore/core/CMakeLists.txt
parent5fdda3fa837f3138973d754f05aec7f541f806ce (diff)
implement `TargetIdGenerator` in C++ for Firestore (#701)
* implement `TargetIdGenerator` * address changes
Diffstat (limited to 'Firestore/core/src/firebase/firestore/core/CMakeLists.txt')
-rw-r--r--Firestore/core/src/firebase/firestore/core/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/Firestore/core/src/firebase/firestore/core/CMakeLists.txt b/Firestore/core/src/firebase/firestore/core/CMakeLists.txt
new file mode 100644
index 0000000..a62985c
--- /dev/null
+++ b/Firestore/core/src/firebase/firestore/core/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Copyright 2018 Google
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cc_library(
+ firebase_firestore_core
+ SOURCES
+ target_id_generator.cc
+ target_id_generator.h
+)