aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/src/firebase/firestore/auth/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar zxu <zxu@google.com>2018-02-09 14:28:29 -0500
committerGravatar GitHub <noreply@github.com>2018-02-09 14:28:29 -0500
commitd70c23ece0abf7e1c00166e26fa89a670d34a740 (patch)
treea59b6eb10bd3394fee37cdf59bee0b666b92b3f5 /Firestore/core/src/firebase/firestore/auth/CMakeLists.txt
parent633eb7bb8bbce2d31d682bf5255d9ef5a97a29c5 (diff)
port Firestore Auth module in C++ (#733)
* Implement firestore/auth/user * add user to project and some fixes * implement firestore/auth/{credentials_provider,empty_credentials_provider} * implement firestore/auth/firebase_credentials_provider * refactoring firebase_credentials_provider and add (disabled but working) unit test * add auth test to project * address changes * small fix to style and project * fix the firebase_credentials_provider_test * fix style * address changes * revert the change to static mutex_ * remove my custom plist path * fix style * address changes * refactoring FirebaseCredentialsProvider to fix the issue w.r.t. auth global dispatch queue * add /*force_refresh=*/ tag to bool literal for style purpose * Use a shared_ptr/weak_ptr handoff on FirebaseCredentialsProvider (#778) * Revert "refactoring FirebaseCredentialsProvider to fix the issue w.r.t. auth global dispatch queue" This reverts commit 87175a4146267d403a774f138b85f8d3b532fa4b. * Use a shared_ptr/weak_ptr handoff on FirebaseCredentialsProvider This avoids any problems with callsbacks retaining pointers to objects destroyed by a C++ destructor
Diffstat (limited to 'Firestore/core/src/firebase/firestore/auth/CMakeLists.txt')
-rw-r--r--Firestore/core/src/firebase/firestore/auth/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/Firestore/core/src/firebase/firestore/auth/CMakeLists.txt b/Firestore/core/src/firebase/firestore/auth/CMakeLists.txt
new file mode 100644
index 0000000..2241fae
--- /dev/null
+++ b/Firestore/core/src/firebase/firestore/auth/CMakeLists.txt
@@ -0,0 +1,52 @@
+# Copyright 2018 Google
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cc_library(
+ firebase_firestore_auth_base
+ SOURCES
+ credentials_provider.cc
+ credentials_provider.h
+ token.cc
+ token.h
+ user.cc
+ user.h
+ DEPENDS
+ absl_strings
+ firebase_firestore_util
+)
+
+cc_library(
+ firebase_firestore_auth_apple
+ SOURCES
+ firebase_credentials_provider_apple.h
+ firebase_credentials_provider_apple.mm
+ DEPENDS
+ FirebaseCore
+ firebase_firestore_auth_base
+ EXCLUDE_FROM_ALL
+)
+
+if(APPLE)
+ list(APPEND AUTH_DEPENDS firebase_firestore_auth_apple)
+endif()
+
+cc_library(
+ firebase_firestore_auth
+ SOURCES
+ empty_credentials_provider.cc
+ empty_credentials_provider.h
+ DEPENDS
+ ${AUTH_DEPENDS}
+ firebase_firestore_auth_base
+)