aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/src/firebase/firestore/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Konstantin Varlamov <var-const@users.noreply.github.com>2018-03-27 11:50:03 -0400
committerGravatar GitHub <noreply@github.com>2018-03-27 11:50:03 -0400
commit22c226af3f5570514d3d13d82a399577ecd7d280 (patch)
treefc8f3e1ca146297f2993f8391ed3dab9e0f2c153 /Firestore/core/src/firebase/firestore/CMakeLists.txt
parent13aa61633f5a98c8dd0a508e5a404017bc79370e (diff)
C++ migration: make Timestamp class a part of public API (#944)
* move Timestamp from model/ to the root directory; * move Timestamp to top-level firebase namespace and update all references; * add conversions to and from native date types; * add a specialization of std::hash; * add comments to public member functions; * rename nanos -> nanoseconds; * add public headers, including Timestamp, to CMake; * increase test coverage.
Diffstat (limited to 'Firestore/core/src/firebase/firestore/CMakeLists.txt')
-rw-r--r--Firestore/core/src/firebase/firestore/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Firestore/core/src/firebase/firestore/CMakeLists.txt b/Firestore/core/src/firebase/firestore/CMakeLists.txt
index 3f5522c..aad2ebb 100644
--- a/Firestore/core/src/firebase/firestore/CMakeLists.txt
+++ b/Firestore/core/src/firebase/firestore/CMakeLists.txt
@@ -17,6 +17,14 @@ cc_library(
firebase_firestore_types
SOURCES
geo_point.cc
+ timestamp.cc
DEPENDS
firebase_firestore_util
)
+
+# Include the folder with public headers.
+target_include_directories(
+ firebase_firestore_types
+ PUBLIC
+ ${PROJECT_SOURCE_DIR}/core/include
+)