aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/Protos/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar rsgowman <rgowman@google.com>2018-02-13 17:46:09 -0500
committerGravatar GitHub <noreply@github.com>2018-02-13 17:46:09 -0500
commitfe19fca0e521e3765e4ecf6a87b0a3d622a52b92 (patch)
tree24a4485215689063c94d40c764e08f9dee4758ca /Firestore/Protos/CMakeLists.txt
parent95d0411e207e3eea64c035258745021ae20b676a (diff)
Serialize and deserialize null (#783)
* Build (grpc's) nanopb with -DPB_FIELD_16BIT We require (at least) 16 bit fields. (By default, nanopb uses 8 bit fields, ie allowing up to 256 field tags.) Also note that this patch adds this to grpc's nanopb, rather than to our nanopb. We'll need to eventually either: a) we instruct grpc to use our nanopb b) we rely on grpc's nanopb instead of using our own. (^ marked as a TODO for now.) * Add some dependant protos Imported from protobuf. Nanopb requires these to be present (though anything using libprotobuf does not, as these are already built into that.) * Add generated nanopb protos based off of newly added proto definitions * Build the nanopb protos * Serialize and deserialize null
Diffstat (limited to 'Firestore/Protos/CMakeLists.txt')
-rw-r--r--Firestore/Protos/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/Firestore/Protos/CMakeLists.txt b/Firestore/Protos/CMakeLists.txt
new file mode 100644
index 0000000..f20f702
--- /dev/null
+++ b/Firestore/Protos/CMakeLists.txt
@@ -0,0 +1,45 @@
+cc_library(
+ firebase_firestore_protos_nanopb
+ SOURCES
+ nanopb/firestore/local/maybe_document.pb.c
+ nanopb/firestore/local/maybe_document.pb.h
+ nanopb/firestore/local/mutation.pb.c
+ nanopb/firestore/local/mutation.pb.h
+ nanopb/firestore/local/target.pb.c
+ nanopb/firestore/local/target.pb.h
+ nanopb/google/api/annotations.pb.c
+ nanopb/google/api/annotations.pb.h
+ nanopb/google/api/http.pb.c
+ nanopb/google/api/http.pb.h
+ nanopb/google/firestore/v1beta1/common.pb.c
+ nanopb/google/firestore/v1beta1/common.pb.h
+ nanopb/google/firestore/v1beta1/document.pb.c
+ nanopb/google/firestore/v1beta1/document.pb.h
+ nanopb/google/firestore/v1beta1/firestore.pb.c
+ nanopb/google/firestore/v1beta1/firestore.pb.h
+ nanopb/google/firestore/v1beta1/query.pb.c
+ nanopb/google/firestore/v1beta1/query.pb.h
+ nanopb/google/firestore/v1beta1/write.pb.c
+ nanopb/google/firestore/v1beta1/write.pb.h
+ nanopb/google/protobuf/any.pb.c
+ nanopb/google/protobuf/any.pb.h
+ nanopb/google/protobuf/empty.pb.c
+ nanopb/google/protobuf/empty.pb.h
+ nanopb/google/protobuf/struct.pb.c
+ nanopb/google/protobuf/struct.pb.h
+ nanopb/google/protobuf/timestamp.pb.c
+ nanopb/google/protobuf/timestamp.pb.h
+ nanopb/google/protobuf/wrappers.pb.c
+ nanopb/google/protobuf/wrappers.pb.h
+ nanopb/google/rpc/status.pb.c
+ nanopb/google/rpc/status.pb.h
+ nanopb/google/type/latlng.pb.c
+ nanopb/google/type/latlng.pb.h
+ DEPENDS
+ nanopb
+)
+
+target_compile_definitions(
+ firebase_firestore_protos_nanopb PUBLIC
+ -DPB_FIELD_16BIT
+)