aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/Protos/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-07-16 08:50:53 -0700
committerGravatar GitHub <noreply@github.com>2018-07-16 08:50:53 -0700
commitcda87fa3afdacf20a097cf6ed90c5c2ef64e0437 (patch)
treeaeda6e64b1b925b7bb8a5dc8189d3c35efa31c4a /Firestore/Protos/CMakeLists.txt
parente963b606f3e90033086e08c1b989153467015ecd (diff)
Convert grpc and protobuf CMake builds to add_subdirectory (#1537)
* Build zlib with grpc's add_subdirectory * Build grpc and its children with add_subdirectory. * Build c-ares with grpc's add_subdirectory * Convert protobuf to a download-only ExternalProject * Temporarily break protobuf within grpc This works because libgrpc has no actual dependency on protobuf * Update boringssl to master@{2018-07-10}
Diffstat (limited to 'Firestore/Protos/CMakeLists.txt')
-rw-r--r--Firestore/Protos/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/Firestore/Protos/CMakeLists.txt b/Firestore/Protos/CMakeLists.txt
index 214c15f..c2132ae 100644
--- a/Firestore/Protos/CMakeLists.txt
+++ b/Firestore/Protos/CMakeLists.txt
@@ -97,8 +97,3 @@ target_include_directories(
firebase_firestore_protos_libprotobuf PUBLIC
${FIREBASE_SOURCE_DIR}/Firestore/Protos/cpp
)
-
-set_target_properties(
- firebase_firestore_protos_libprotobuf
- PROPERTIES COMPILE_FLAGS "-Wno-unused-parameter"
-)