aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar rsgowman <rgowman@google.com>2018-02-13 17:46:09 -0500
committerGravatar GitHub <noreply@github.com>2018-02-13 17:46:09 -0500
commitfe19fca0e521e3765e4ecf6a87b0a3d622a52b92 (patch)
tree24a4485215689063c94d40c764e08f9dee4758ca /Firestore/CMakeLists.txt
parent95d0411e207e3eea64c035258745021ae20b676a (diff)
Serialize and deserialize null (#783)
* Build (grpc's) nanopb with -DPB_FIELD_16BIT We require (at least) 16 bit fields. (By default, nanopb uses 8 bit fields, ie allowing up to 256 field tags.) Also note that this patch adds this to grpc's nanopb, rather than to our nanopb. We'll need to eventually either: a) we instruct grpc to use our nanopb b) we rely on grpc's nanopb instead of using our own. (^ marked as a TODO for now.) * Add some dependant protos Imported from protobuf. Nanopb requires these to be present (though anything using libprotobuf does not, as these are already built into that.) * Add generated nanopb protos based off of newly added proto definitions * Build the nanopb protos * Serialize and deserialize null
Diffstat (limited to 'Firestore/CMakeLists.txt')
-rw-r--r--Firestore/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Firestore/CMakeLists.txt b/Firestore/CMakeLists.txt
index 25f27fa..28ac08f 100644
--- a/Firestore/CMakeLists.txt
+++ b/Firestore/CMakeLists.txt
@@ -68,3 +68,4 @@ include_directories(${FIREBASE_SOURCE_DIR})
include_directories(${FIREBASE_SOURCE_DIR}/Firestore/Protos/nanopb)
add_subdirectory(core)
+add_subdirectory(Protos)