aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-01-16 10:17:27 -0800
committerGravatar zxu <zxu@google.com>2018-01-16 13:17:27 -0500
commitdf71c9ad8c2751672b8ae85915cc7f74f3db08c8 (patch)
treea9ff559e2f3190279d1442a6e3217a77c2e916d8 /Firestore/CMakeLists.txt
parent2700198d93647da858714d3d80fe2b66fe4aac54 (diff)
Enable warnings in the CMake build (#669)
* Enable warnings when building with GCC or clang * Fix warnings
Diffstat (limited to 'Firestore/CMakeLists.txt')
-rw-r--r--Firestore/CMakeLists.txt23
1 files changed, 4 insertions, 19 deletions
diff --git a/Firestore/CMakeLists.txt b/Firestore/CMakeLists.txt
index 4e009e0..553f59c 100644
--- a/Firestore/CMakeLists.txt
+++ b/Firestore/CMakeLists.txt
@@ -36,27 +36,12 @@ if(APPLE)
find_package(FirebaseCore REQUIRED)
endif()
-# We use C++11
-set(CMAKE_CXX_STANDARD 11)
-set(CMAKE_CXX_STANDARD_REQUIRED ON)
-set(CMAKE_CXX_EXTENSIONS OFF)
+enable_testing()
+add_subdirectory(third_party/abseil-cpp)
+
+include(CompilerSetup)
# Fully qualified imports, project wide
include_directories(${FIREBASE_SOURCE_DIR})
-if(APPLE)
- # CMake has no special support for Objective-C as a distinct language but enabling modules and
- # other clang extensions would apply even to regular C++ sources which is nonportable. Keep these
- # flags separate to avoid misuse.
- set(
- OBJC_FLAGS
- -fobjc-arc
- -fmodules
- -fno-autolink
- -F${FIREBASE_INSTALL_DIR}/Frameworks
- )
-endif(APPLE)
-
-enable_testing()
-add_subdirectory(third_party/abseil-cpp)
add_subdirectory(core)