aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-01-19 12:20:46 -0800
committerGravatar GitHub <noreply@github.com>2018-01-19 12:20:46 -0800
commit9f7c094f9f00a6efc0107071f109ef1bc4d7357d (patch)
tree98326bf2f1190338ddc451ea5418bbc4b3348008 /Firestore/CMakeLists.txt
parent6a6e14822fc8c4ec16e9045b23b515b4baad14fd (diff)
Add platform detection logic for SecureRandom (#676)
* Add CMake platform detection logic for SecureRandom Now only builds secure_random_arc4random.cc if available. Remove firebase/firestore/base/port.h. Nothing else was in that directory. * Add a SecureRandom implementation that uses OpenSSL This is usable on Linux, Windows, and Android * Properly check return from RAND_bytes
Diffstat (limited to 'Firestore/CMakeLists.txt')
-rw-r--r--Firestore/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Firestore/CMakeLists.txt b/Firestore/CMakeLists.txt
index 499e06c..b8c95c6 100644
--- a/Firestore/CMakeLists.txt
+++ b/Firestore/CMakeLists.txt
@@ -57,6 +57,9 @@ add_subdirectory(third_party/abseil-cpp)
include(CompilerSetup)
+# Generated sources will be relative to the binary directory.
+include_directories(${FIREBASE_INSTALL_DIR})
+
# Fully qualified imports, project wide
include_directories(${FIREBASE_SOURCE_DIR})