aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Konstantin Varlamov <var-const@users.noreply.github.com>2018-04-12 12:15:28 -0400
committerGravatar GitHub <noreply@github.com>2018-04-12 12:15:28 -0400
commit97844711be9a44aa086eccbee1ebc1d79b6db978 (patch)
tree2c365acd6f01c14eaa27a92fa8488a1208127151 /Firestore/CMakeLists.txt
parent6f2ef7d3899f05dae7eb03847d8dddf9b04a7738 (diff)
Add CMake options to build using sanitizers (#1053)
Example run: `cmake -DWITH_ASAN=ON ..` (from Firestore build folder)
Diffstat (limited to 'Firestore/CMakeLists.txt')
-rw-r--r--Firestore/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/Firestore/CMakeLists.txt b/Firestore/CMakeLists.txt
index d605411..80308bb 100644
--- a/Firestore/CMakeLists.txt
+++ b/Firestore/CMakeLists.txt
@@ -15,6 +15,48 @@
cmake_minimum_required(VERSION 2.8.11)
project(firestore C CXX)
+option(WITH_ASAN "Build with Address Sanitizer" OFF)
+# TODO(varconst): msan
+# Memory sanitizer is more complicated:
+# - it requires all dependencies to be compiled with msan enabled (see
+# https://github.com/google/sanitizers/wiki/MemorySanitizerLibcxxHowTo);
+# - AppleClang doesn't support it.
+option(WITH_TSAN "Build with Thread Sanitizer (mutually exculsive with other sanitizers)" OFF)
+option(WITH_UBSAN "Build with Undefined Behavior sanitizer" OFF)
+
+macro(add_to_compile_and_link_flags flag)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${flag}")
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} ${flag}")
+endmacro()
+
+if(CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
+ if(WITH_ASAN)
+ add_to_compile_and_link_flags("-fsanitize=address")
+ endif()
+
+ if(WITH_TSAN)
+ if(WITH_ASAN OR WITH_UBSAN)
+ message(FATAL_ERROR "Cannot combine TSan with other santizers")
+ endif()
+ add_to_compile_and_link_flags("-fsanitize=thread")
+ endif()
+
+ if(WITH_UBSAN)
+ add_to_compile_and_link_flags("-fsanitize=undefined")
+ endif()
+
+ if (WITH_ASAN OR WITH_TSAN OR WITH_UBSAN)
+ # Recommended to "get nicer stack traces in error messages"
+ # TODO(varconst): double-check that TSan actually needs this flag (it's
+ # explicitly recommended in the docs for ASan and UBSan)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-omit-frame-pointer")
+ endif()
+else()
+ if(WITH_ASAN OR WITH_TSAN OR WITH_UBSAN)
+ message(FATAL_ERROR "Only Clang and GCC support sanitizers")
+ endif()
+endif()
+
set(FIREBASE_SOURCE_DIR ${CMAKE_CURRENT_LIST_DIR}/..)
# CMAKE_INSTALL_PREFIX should be passed in to this build so that it can find