aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2017-12-12 11:13:02 -0800
committerGravatar GitHub <noreply@github.com>2017-12-12 11:13:02 -0800
commit87d88ebbe2b325f8b172af6f519a1070d94f39cb (patch)
tree9732bef72b9902b629c7f8b3168eda812a4165d3 /Firestore/CMakeLists.txt
parenta4d2614d73ccea3bac9dbade6b13326cbfc8cabc (diff)
Add leveldb to the Firestore cmake build (#559)
* Use Debug as the default build type if unspecified * Add a leveldb ExternalProject, FindLevelDB module, and use it in Firestore * Accept an externally built leveldb via LEVELDB_ROOT * Clone leveldb via https: instead of git: * Remove extra DOWNLOAD_DIR which doesn't work with GIT sources
Diffstat (limited to 'Firestore/CMakeLists.txt')
-rw-r--r--Firestore/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Firestore/CMakeLists.txt b/Firestore/CMakeLists.txt
index 6c2a32e..906b6e4 100644
--- a/Firestore/CMakeLists.txt
+++ b/Firestore/CMakeLists.txt
@@ -16,9 +16,13 @@ cmake_minimum_required(VERSION 2.8.11)
project(firestore)
set(FIREBASE_SOURCE_DIR "${CMAKE_CURRENT_LIST_DIR}/..")
-include("${FIREBASE_SOURCE_DIR}/cmake/utils.cmake")
+set(FIREBASE_BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/..")
+
+list(INSERT CMAKE_MODULE_PATH 0 ${FIREBASE_SOURCE_DIR}/cmake)
+include(utils)
find_package(GTest REQUIRED)
+find_package(LevelDB REQUIRED)
# We use C++11
set(CMAKE_CXX_STANDARD 11)