aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Rich Gowman <rgowman@google.com>2018-02-02 14:12:51 -0500
committerGravatar Rich Gowman <rgowman@google.com>2018-02-06 10:02:30 -0500
commit3fcdf510ce4b7f50e44445ff329d9019e73ba257 (patch)
treee6d76f82d838e3d8a3ee852be40c4676a19e3552 /Firestore/CMakeLists.txt
parent9a71ce8e677cdd1bff4c8fd21666a074d1e893b7 (diff)
Hook up nanopb to firestorep project
Use remote/serializer placeholder class as a hook for the test to ensure nanopb headers can be found, and test can be linked.
Diffstat (limited to 'Firestore/CMakeLists.txt')
-rw-r--r--Firestore/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Firestore/CMakeLists.txt b/Firestore/CMakeLists.txt
index b8c95c6..25f27fa 100644
--- a/Firestore/CMakeLists.txt
+++ b/Firestore/CMakeLists.txt
@@ -47,6 +47,7 @@ add_library(
find_package(LevelDB REQUIRED)
find_package(GRPC REQUIRED)
+find_package(Nanopb REQUIRED)
if(APPLE)
find_package(FirebaseCore REQUIRED)
@@ -63,4 +64,7 @@ include_directories(${FIREBASE_INSTALL_DIR})
# Fully qualified imports, project wide
include_directories(${FIREBASE_SOURCE_DIR})
+# Include nanopb generated sources
+include_directories(${FIREBASE_SOURCE_DIR}/Firestore/Protos/nanopb)
+
add_subdirectory(core)