aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2017-11-20 14:38:44 -0800
committerGravatar GitHub <noreply@github.com>2017-11-20 14:38:44 -0800
commit1670f1c5ddf1d9b4fab6b9b6d0e00323af48e967 (patch)
tree98eb2ba2de062ed5b6564db306e2453b75c1dd88 /Firestore/CMakeLists.txt
parent4a1f29b9b3f742cc722af9f5f2a77e3aad89022e (diff)
Initial CMake-based build (#472)
Initial CMake-based build This knows how to download and build googletest.
Diffstat (limited to 'Firestore/CMakeLists.txt')
-rw-r--r--Firestore/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/Firestore/CMakeLists.txt b/Firestore/CMakeLists.txt
new file mode 100644
index 0000000..99f0ab1
--- /dev/null
+++ b/Firestore/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Copyright 2017 Google
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+include(${PROJECT_SOURCE_DIR}/cmake/external/googletest.cmake)