aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-01-01 21:00:32 -0800
committerGravatar GitHub <noreply@github.com>2018-01-01 21:00:32 -0800
commit13da48d8a4fcdfe288fa15c788c59e7f54edf42c (patch)
tree059bbfffe76ff01eb8241d468e23b22b68001d69 /Firestore/CMakeLists.txt
parent412e759a19117974cca18e86ea44742ae0dec659 (diff)
Build FirebaseCore from CMake (#594)
* Don't bother specifying a download directory to CMake ExternalProject * Teach CMake to build pure Xcode projects as dependencies This allows downstream code (like log_apple.mm) to consume this for testing within the CMake build without requiring a CMake-native build for these components. This makes integrating these components into the cmake build essentially free from the point of view of the consumed component. * Get the CMake build semi-working on Linux again Many prebuilt versions of cmake on Linux lack the ability to download over https so use git to get googletest. Don't attempt to build FirebaseCore on Linux; there's no xcodebuild. Note the build is still ultimately broken because we don't yet have an alternative to arc4random on Linux but at least this is no more broken than it was before.
Diffstat (limited to 'Firestore/CMakeLists.txt')
-rw-r--r--Firestore/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Firestore/CMakeLists.txt b/Firestore/CMakeLists.txt
index 906b6e4..ba9998d 100644
--- a/Firestore/CMakeLists.txt
+++ b/Firestore/CMakeLists.txt
@@ -24,6 +24,10 @@ include(utils)
find_package(GTest REQUIRED)
find_package(LevelDB REQUIRED)
+if(APPLE)
+ find_package(FirebaseCore REQUIRED)
+endif()
+
# We use C++11
set(CMAKE_CXX_STANDARD 11)
set(CMAKE_CXX_STANDARD_REQUIRED ON)