aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2017-12-12 11:13:02 -0800
committerGravatar GitHub <noreply@github.com>2017-12-12 11:13:02 -0800
commit87d88ebbe2b325f8b172af6f519a1070d94f39cb (patch)
tree9732bef72b9902b629c7f8b3168eda812a4165d3 /CMakeLists.txt
parenta4d2614d73ccea3bac9dbade6b13326cbfc8cabc (diff)
Add leveldb to the Firestore cmake build (#559)
* Use Debug as the default build type if unspecified * Add a leveldb ExternalProject, FindLevelDB module, and use it in Firestore * Accept an externally built leveldb via LEVELDB_ROOT * Clone leveldb via https: instead of git: * Remove extra DOWNLOAD_DIR which doesn't work with GIT sources
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index efea997..63e1a39 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,11 @@
cmake_minimum_required(VERSION 2.8.11)
project(firebase C CXX)
+# If no build type is specified, make it a debug build
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE Debug)
+endif()
+
list(INSERT CMAKE_MODULE_PATH 0 ${PROJECT_SOURCE_DIR}/cmake)
# External Projects install into this prefix and download into the source tree
@@ -27,5 +32,6 @@ set(FIREBASE_DOWNLOAD_DIR "${PROJECT_SOURCE_DIR}/.downloads")
enable_testing()
include(external/googletest)
+include(external/leveldb)
include(external/abseil-cpp)
include(external/firestore)