aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Konstantin Varlamov <var-const@users.noreply.github.com>2018-04-23 14:11:27 -0400
committerGravatar GitHub <noreply@github.com>2018-04-23 14:11:27 -0400
commit758b29aec4c2a76bd85f521ba652ceedd11313f1 (patch)
treec67e4ff4eb649278f50094a05f33f22b304099e8 /CMakeLists.txt
parente4384c3e809556e75907df74cd116307f397472f (diff)
Firestore Travis: add test runs using sanitizers (#1128)
Also move most of `before_install` actions from Travis config into scripts to reduce duplication.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 15b68b5..04d4c99 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,10 @@
cmake_minimum_required(VERSION 2.8.11)
project(firebase C CXX)
+option(WITH_ASAN "Build with Address Sanitizer" OFF)
+option(WITH_TSAN "Build with Thread Sanitizer (mutually exculsive with other sanitizers)" OFF)
+option(WITH_UBSAN "Build with Undefined Behavior sanitizer" OFF)
+
# If no build type is specified, make it a debug build
if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE Debug)