aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2017-12-06 16:10:59 -0800
committerGravatar GitHub <noreply@github.com>2017-12-06 16:10:59 -0800
commit32bdc38400258b24edb37990cc8cba057a3297de (patch)
tree1bf6bfda76e3fd5d0119d63d4544e9d6710ce264 /CMakeLists.txt
parentcb5f3efd3ab53561afd7de625d16d014d14374dd (diff)
Rework the top-level cmake build to be a superproject (#538)
All projects are now ExternalProjects This makes it much easier to build them all in a single pass.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 10 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 53b454d..f9e7527 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,22 +12,19 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+# Superbuild for Firebase
+
cmake_minimum_required(VERSION 2.8.11)
project(firebase C CXX)
-# We use C++11
-set(CMAKE_CXX_STANDARD 11)
-set(CMAKE_CXX_STANDARD_REQUIRED ON)
-set(CMAKE_CXX_EXTENSIONS OFF)
-
-# Fully qualified imports, project wide
-include_directories("${PROJECT_SOURCE_DIR}")
+list(INSERT CMAKE_MODULE_PATH 0 ${PROJECT_SOURCE_DIR}/cmake)
-# CMake's test target does not build tests before running them. This adds a
-# check target that
-add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND} --output-on-failure)
-
-include(cmake/utils.cmake)
+# External Projects install into this prefix and download into the source tree
+# to avoid re-downloading repeatedly during development.
+set(FIREBASE_INSTALL_DIR "${PROJECT_BINARY_DIR}/usr")
+set(FIREBASE_DOWNLOAD_DIR "${PROJECT_SOURCE_DIR}/.downloads")
enable_testing()
-add_subdirectory(Firestore)
+
+include(external/googletest)
+include(external/firestore)