aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-06-26 11:58:10 -0700
committerGravatar GitHub <noreply@github.com>2018-06-26 11:58:10 -0700
commit2810a09c582b09104c04f16e5a3086cbe3e79d23 (patch)
tree0f9d6fac5ae1c22dfe33d575ef186bd6df5db764 /CMakeLists.txt
parent6e3dc15ce702b2446e33e03ebe5e6d372c6a00a6 (diff)
Prepare for installed sub-projects (#1459)
* Ignore vim backup files * Prepare for installed subprojects This adds FIREBASE_BINARY_DIR to point to the out-of-source build directory (which previously was passed around as FIREBASE_INSTALL_DIR). This repurposes FIREBASE_INSTALL_DIR to point to ${FIREBASE_BINARY_DIR}/opt, and installation root for subprojects that have an install step. * Allow download directory to be specified
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 04d4c99..ca5c322 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,7 +36,14 @@ endif(APPLE)
list(INSERT CMAKE_MODULE_PATH 0 ${PROJECT_SOURCE_DIR}/cmake)
-set(FIREBASE_INSTALL_DIR ${PROJECT_BINARY_DIR})
+set(FIREBASE_BINARY_DIR ${PROJECT_BINARY_DIR})
+set(FIREBASE_INSTALL_DIR ${PROJECT_BINARY_DIR}/opt)
+
+set(
+ FIREBASE_DOWNLOAD_DIR
+ ${PROJECT_BINARY_DIR}/downloads
+ CACHE PATH "Where to store downloaded files"
+)
enable_testing()