aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2017-11-20 14:38:44 -0800
committerGravatar GitHub <noreply@github.com>2017-11-20 14:38:44 -0800
commit1670f1c5ddf1d9b4fab6b9b6d0e00323af48e967 (patch)
tree98eb2ba2de062ed5b6564db306e2453b75c1dd88 /CMakeLists.txt
parent4a1f29b9b3f742cc722af9f5f2a77e3aad89022e (diff)
Initial CMake-based build (#472)
Initial CMake-based build This knows how to download and build googletest.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..83950a9
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Copyright 2017 Google
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cmake_minimum_required(VERSION 2.8.11)
+project(firebase C CXX)
+
+# We use C++11
+set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+set(CMAKE_CXX_EXTENSIONS OFF)
+
+# Fully qualified imports, project wide
+include_directories("${PROJECT_SOURCE_DIR}")
+
+# CMake's test target does not build tests before running them. This adds a
+# check target that
+add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND} --output-on-failure)
+
+enable_testing()
+add_subdirectory(Firestore)