aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-01-08 08:57:36 -0800
committerGravatar GitHub <noreply@github.com>2018-01-08 08:57:36 -0800
commit0f6103e4048242aa066b4ae0e0473578b50b559c (patch)
tree7f5e450db0a866f29a5bd0e64f7a40e6a264825e /CMakeLists.txt
parentbc74670afec651c3f912cb6b7e54f5b68bd507f5 (diff)
Port StringPrintf from //base (#624)
* Port StringPrintf from //base. Prefer this to approaches based on variadic templates. While the variadic template mechanisms are strictly safer, they result in binary bloat we can't afford. This is essentially the same StringPrintf previously open sourced as a part of protobuf, though updated for C++11 which saves a copy and a temporary buffer on the heap. * Add abseil as a subdirectory of Firestore This saves having to redefine all the libraries that abseil defines as imported libraries. * Rename firebase_firesture_util_log_* targets Cut the log out of the name to reflect that these will get more components besides just logging.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 52a4376..edcd611 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,5 +40,4 @@ include(external/FirebaseCore)
include(external/googletest)
include(external/leveldb)
-include(external/abseil-cpp)
include(external/firestore)