aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/basicstuff.cpp
Commit message (Expand)AuthorAge
...
* Make use of the LazyBit, introduce .lazy(), remove lazyProduct.Gravatar Benoit Jacob2008-03-31
* * introducte recursive Flags system for the expressionsGravatar Benoit Jacob2008-03-30
* generalized ei_traits<>.Gravatar Benoit Jacob2008-03-12
* Extended the comma initializer to support xpr on the right side:Gravatar Gael Guennebaud2008-03-08
* * Added support for a comma initializer: mat.block(i,j,2,2) << 1, 2, 3, 4;Gravatar Gael Guennebaud2008-03-08
* * Fix a compilation issue with large fixed-size matrices: the unrollers were...Gravatar Gael Guennebaud2008-03-05
* Removed trailling spaces.Gravatar Gael Guennebaud2008-03-03
* Relicense --> dual-license LGPL3+/GPL2+Gravatar Benoit Jacob2008-02-28
* prefix global functions with ei_ as previous solution was ratherGravatar Benoit Jacob2008-02-28
* rework Identity API: no longer restricted to square matricesGravatar Benoit Jacob2008-01-11
* Ready for alpha2 release.Gravatar Benoit Jacob2008-01-07
* - move: DerivedTraits becomes MatrixBase::TraitsGravatar Benoit Jacob2008-01-06
* - eigen2 now fully enforces constness! found a way to achieve thatGravatar Benoit Jacob2007-12-25
* split the coeffs accessors/mutators into a separate Coeffs.h fileGravatar Benoit Jacob2007-12-18
* add matrix constructor taking an array. update unit-tests.Gravatar Benoit Jacob2007-12-18
* -add Ones, DiagonalMatrix, DiagonalCoeffsGravatar Benoit Jacob2007-12-15
* expand unit-tests and fix const-qualifaction bugs thus discoveredGravatar Benoit Jacob2007-12-12
* Expand and improve unit-testsGravatar Benoit Jacob2007-12-11
* rename Block to DynBlock and rework API to make place forGravatar Benoit Jacob2007-12-05
* Rework the unit-tests to use lower precision, so as to eliminateGravatar Benoit Jacob2007-12-03
* Test application now takes 'seed' and 'repeat' command-line argsGravatar Benoit Jacob2007-12-03
* Much more convenient, less over-engineered NumTraits. Done during this KDE-Ed...Gravatar Benoit Jacob2007-12-02
* add more unit-tests (covering transpose, conjugate, adjoint, dot product...)Gravatar Benoit Jacob2007-11-28
* rename Object -> MatrixBaseGravatar Benoit Jacob2007-11-27
* - improve and comment the "BasicStuff" test.Gravatar Benoit Jacob2007-11-26
* Merge WrapArray into FromArray. Less code. The downside is that we're using o...Gravatar Benoit Jacob2007-10-14
* restrict identity() to square matrices; small change helping g++ optimize.Gravatar Benoit Jacob2007-10-14
* add zero() and identity() static methods, update unit-testsGravatar Benoit Jacob2007-10-14
* remove support for type std::complex<int>. Simplify NumTraits accordingly.Gravatar Benoit Jacob2007-10-14
* implement the first _real_ unit-tests, testing the results for correctness in...Gravatar Benoit Jacob2007-10-13