aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unsupported/CMakeLists.txt')
-rw-r--r--unsupported/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/unsupported/CMakeLists.txt b/unsupported/CMakeLists.txt
index 9a5666105..34408c017 100644
--- a/unsupported/CMakeLists.txt
+++ b/unsupported/CMakeLists.txt
@@ -1,5 +1,7 @@
add_subdirectory(Eigen)
-add_subdirectory(doc EXCLUDE_FROM_ALL)
+if(EIGEN_BUILD_DOC)
+ add_subdirectory(doc EXCLUDE_FROM_ALL)
+endif()
if(BUILD_TESTING)
if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest