aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 75e4e116d..7af5b531f 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -19,14 +19,15 @@ endif(GSL_FOUND)
option(EIGEN_TEST_NOQT "Disable Qt support in unit tests" OFF)
if(NOT EIGEN_TEST_NOQT)
+ message("----------------> find qt")
find_package(Qt4)
endif(NOT EIGEN_TEST_NOQT)
-if(QT4_FOUND)
+if(EIGEN_TEST_NOQT AND QT4_FOUND)
include(${QT_USE_FILE})
ei_add_property(EIGEN_TESTED_BACKENDS "Qt4 support, ")
-else(QT4_FOUND)
+else()
ei_add_property(EIGEN_MISSING_BACKENDS "Qt4 support, ")
-endif(QT4_FOUND)
+endif()
if(TEST_LIB)
add_definitions("-DEIGEN_EXTERN_INSTANTIATIONS=1")