aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/snippets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/snippets/CMakeLists.txt')
-rw-r--r--doc/snippets/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/doc/snippets/CMakeLists.txt b/doc/snippets/CMakeLists.txt
index cf3f6de4f..88ed3419f 100644
--- a/doc/snippets/CMakeLists.txt
+++ b/doc/snippets/CMakeLists.txt
@@ -18,6 +18,9 @@ foreach(snippet_src ${snippets_SRCS})
if(${snippet_src} MATCHES "cxx11")
set_target_properties(${compile_snippet_target} PROPERTIES COMPILE_FLAGS "-std=c++11")
endif()
+ if(${snippet_src} MATCHES "deprecated")
+ set_target_properties(${compile_snippet_target} PROPERTIES COMPILE_FLAGS "-DEIGEN_NO_DEPRECATED_WARNING")
+ endif()
add_custom_command(
TARGET ${compile_snippet_target}
POST_BUILD