aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 90228f071..39af38afe 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -5,7 +5,19 @@ CONFIGURE_FILE(
${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
)
+SET(examples_targets "")
+SET(snippets_targets "")
+
ADD_SUBDIRECTORY(examples)
ADD_SUBDIRECTORY(snippets)
+ADD_CUSTOM_TARGET(
+ run_doxygen
+ ALL
+ COMMAND doxygen
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+ADD_DEPENDENCIES(run_doxygen all_snippets all_examples)
+
ENDIF(BUILD_DOC)