aboutsummaryrefslogtreecommitdiffhomepage
path: root/demos/opengl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'demos/opengl/CMakeLists.txt')
-rw-r--r--demos/opengl/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/demos/opengl/CMakeLists.txt b/demos/opengl/CMakeLists.txt
new file mode 100644
index 000000000..8fd02551a
--- /dev/null
+++ b/demos/opengl/CMakeLists.txt
@@ -0,0 +1,17 @@
+
+FIND_PACKAGE(Qt4 REQUIRED)
+
+set(QT_USE_QTOPENGL TRUE)
+include(${QT_USE_FILE})
+
+SET(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+INCLUDE_DIRECTORIES( ${QT_INCLUDE_DIR} )
+
+SET(quaternion_demo_SRCS gpuhelper.cpp camera.cpp trackball.cpp quaternion_demo.cpp)
+
+QT4_AUTOMOC(${quaternion_demo_SRCS})
+
+ADD_EXECUTABLE(quaternion_demo ${quaternion_demo_SRCS})
+
+TARGET_LINK_LIBRARIES(quaternion_demo ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${QT_QTOPENGL_LIBRARY})