aboutsummaryrefslogtreecommitdiffhomepage
path: root/bench/btl/libs/blaze/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bench/btl/libs/blaze/CMakeLists.txt')
-rw-r--r--bench/btl/libs/blaze/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/bench/btl/libs/blaze/CMakeLists.txt b/bench/btl/libs/blaze/CMakeLists.txt
new file mode 100644
index 000000000..54ab929d8
--- /dev/null
+++ b/bench/btl/libs/blaze/CMakeLists.txt
@@ -0,0 +1,8 @@
+
+find_package(BLAZE)
+find_package(Boost)
+if (BLAZE_FOUND AND Boost_FOUND)
+ include_directories(${BLAZE_INCLUDE_DIR} ${Boost_INCLUDE_DIRS})
+ btl_add_bench(btl_blaze main.cpp)
+ target_link_libraries(btl_blaze ${Boost_LIBRARIES} ${Boost_system_LIBRARY} /opt/local/lib/libboost_system-mt.a )
+endif (BLAZE_FOUND)