aboutsummaryrefslogtreecommitdiffhomepage
path: root/bench/btl/libs/blaze/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bench/btl/libs/blaze/CMakeLists.txt')
-rw-r--r--bench/btl/libs/blaze/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/bench/btl/libs/blaze/CMakeLists.txt b/bench/btl/libs/blaze/CMakeLists.txt
index f8b1b2ec3..e99a0855c 100644
--- a/bench/btl/libs/blaze/CMakeLists.txt
+++ b/bench/btl/libs/blaze/CMakeLists.txt
@@ -1,10 +1,13 @@
find_package(BLAZE)
-find_package(Boost)
+find_package(Boost COMPONENTS system)
if (BLAZE_FOUND AND Boost_FOUND)
include_directories(${BLAZE_INCLUDE_DIR} ${Boost_INCLUDE_DIRS})
btl_add_bench(btl_blaze main.cpp)
+ # Note: The newest blaze version requires C++14.
+ # Ideally, we should set this depending on the version of Blaze we found
+ set_property(TARGET btl_blaze PROPERTY CXX_STANDARD 14)
if(BUILD_btl_blaze)
- target_link_libraries(btl_blaze ${Boost_LIBRARIES} ${Boost_system_LIBRARY} /opt/local/lib/libboost_system-mt.a )
+ target_link_libraries(btl_blaze ${Boost_LIBRARIES})
endif()
endif ()