aboutsummaryrefslogtreecommitdiffhomepage
path: root/bench/btl/libs/C_BLAS/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bench/btl/libs/C_BLAS/CMakeLists.txt')
-rw-r--r--bench/btl/libs/C_BLAS/CMakeLists.txt18
1 files changed, 14 insertions, 4 deletions
diff --git a/bench/btl/libs/C_BLAS/CMakeLists.txt b/bench/btl/libs/C_BLAS/CMakeLists.txt
index ec6a74aa1..59065cb9b 100644
--- a/bench/btl/libs/C_BLAS/CMakeLists.txt
+++ b/bench/btl/libs/C_BLAS/CMakeLists.txt
@@ -1,7 +1,7 @@
find_package(ATLAS)
if (ATLAS_FOUND)
- include_directories(${ATLAS_INCLUDES} ${PROJECT_SOURCE_DIR}/libs/f77)
+ include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
btl_add_bench(btl_atlas main.cpp)
if(BUILD_btl_atlas)
target_link_libraries(btl_atlas ${ATLAS_LIBRARIES})
@@ -11,7 +11,7 @@ endif (ATLAS_FOUND)
find_package(MKL)
if (MKL_FOUND)
- include_directories(${MKL_INCLUDES} ${PROJECT_SOURCE_DIR}/libs/f77)
+ include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
btl_add_bench(btl_mkl main.cpp)
if(BUILD_btl_mkl)
target_link_libraries(btl_mkl ${MKL_LIBRARIES})
@@ -21,7 +21,7 @@ endif (MKL_FOUND)
find_package(GOTO)
if (GOTO_FOUND)
- include_directories(${GOTO_INCLUDES} ${PROJECT_SOURCE_DIR}/libs/f77)
+ include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
btl_add_bench(btl_goto main.cpp)
if(BUILD_btl_goto)
target_link_libraries(btl_goto ${GOTO_LIBRARIES} )
@@ -30,9 +30,19 @@ if (GOTO_FOUND)
endif (GOTO_FOUND)
+find_package(GOTO2)
+if (GOTO2_FOUND)
+ include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
+ btl_add_bench(btl_goto2 main.cpp)
+ if(BUILD_btl_goto2)
+ target_link_libraries(btl_goto2 ${GOTO_LIBRARIES} )
+ set_target_properties(btl_goto2 PROPERTIES COMPILE_FLAGS "-DCBLASNAME=GOTO2 -DPUREBLAS")
+ endif(BUILD_btl_goto2)
+endif (GOTO2_FOUND)
+
find_package(ACML)
if (ACML_FOUND)
- include_directories(${ACML_INCLUDES} ${PROJECT_SOURCE_DIR}/libs/f77)
+ include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
btl_add_bench(btl_acml main.cpp)
if(BUILD_btl_acml)
target_link_libraries(btl_acml ${ACML_LIBRARIES} )