aboutsummaryrefslogtreecommitdiffhomepage
path: root/bench/btl/libs/BLAS/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bench/btl/libs/BLAS/CMakeLists.txt')
-rw-r--r--bench/btl/libs/BLAS/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/bench/btl/libs/BLAS/CMakeLists.txt b/bench/btl/libs/BLAS/CMakeLists.txt
new file mode 100644
index 000000000..59065cb9b
--- /dev/null
+++ b/bench/btl/libs/BLAS/CMakeLists.txt
@@ -0,0 +1,51 @@
+
+find_package(ATLAS)
+if (ATLAS_FOUND)
+ include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
+ btl_add_bench(btl_atlas main.cpp)
+ if(BUILD_btl_atlas)
+ target_link_libraries(btl_atlas ${ATLAS_LIBRARIES})
+ set_target_properties(btl_atlas PROPERTIES COMPILE_FLAGS "-DCBLASNAME=ATLAS -DHAS_LAPACK=1")
+ endif(BUILD_btl_atlas)
+endif (ATLAS_FOUND)
+
+find_package(MKL)
+if (MKL_FOUND)
+ include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
+ btl_add_bench(btl_mkl main.cpp)
+ if(BUILD_btl_mkl)
+ target_link_libraries(btl_mkl ${MKL_LIBRARIES})
+ set_target_properties(btl_mkl PROPERTIES COMPILE_FLAGS "-DCBLASNAME=INTEL_MKL -DHAS_LAPACK=1")
+ endif(BUILD_btl_mkl)
+endif (MKL_FOUND)
+
+find_package(GOTO)
+if (GOTO_FOUND)
+ include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
+ btl_add_bench(btl_goto main.cpp)
+ if(BUILD_btl_goto)
+ target_link_libraries(btl_goto ${GOTO_LIBRARIES} )
+ set_target_properties(btl_goto PROPERTIES COMPILE_FLAGS "-DCBLASNAME=GOTO -DPUREBLAS")
+ endif(BUILD_btl_goto)
+endif (GOTO_FOUND)
+
+
+find_package(GOTO2)
+if (GOTO2_FOUND)
+ include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
+ btl_add_bench(btl_goto2 main.cpp)
+ if(BUILD_btl_goto2)
+ target_link_libraries(btl_goto2 ${GOTO_LIBRARIES} )
+ set_target_properties(btl_goto2 PROPERTIES COMPILE_FLAGS "-DCBLASNAME=GOTO2 -DPUREBLAS")
+ endif(BUILD_btl_goto2)
+endif (GOTO2_FOUND)
+
+find_package(ACML)
+if (ACML_FOUND)
+ include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
+ btl_add_bench(btl_acml main.cpp)
+ if(BUILD_btl_acml)
+ target_link_libraries(btl_acml ${ACML_LIBRARIES} )
+ set_target_properties(btl_acml PROPERTIES COMPILE_FLAGS "-DCBLASNAME=ACML -DHAS_LAPACK=1 -DPUREBLAS")
+ endif(BUILD_btl_acml)
+endif (ACML_FOUND)