aboutsummaryrefslogtreecommitdiffhomepage
path: root/bench/btl/libs/BLAS/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bench/btl/libs/BLAS/CMakeLists.txt')
-rw-r--r--bench/btl/libs/BLAS/CMakeLists.txt21
1 files changed, 13 insertions, 8 deletions
diff --git a/bench/btl/libs/BLAS/CMakeLists.txt b/bench/btl/libs/BLAS/CMakeLists.txt
index 59065cb9b..ad3858ee0 100644
--- a/bench/btl/libs/BLAS/CMakeLists.txt
+++ b/bench/btl/libs/BLAS/CMakeLists.txt
@@ -1,7 +1,6 @@
find_package(ATLAS)
if (ATLAS_FOUND)
- include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
btl_add_bench(btl_atlas main.cpp)
if(BUILD_btl_atlas)
target_link_libraries(btl_atlas ${ATLAS_LIBRARIES})
@@ -11,7 +10,6 @@ endif (ATLAS_FOUND)
find_package(MKL)
if (MKL_FOUND)
- include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
btl_add_bench(btl_mkl main.cpp)
if(BUILD_btl_mkl)
target_link_libraries(btl_mkl ${MKL_LIBRARIES})
@@ -21,31 +19,38 @@ endif (MKL_FOUND)
find_package(GOTO)
if (GOTO_FOUND)
- include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
btl_add_bench(btl_goto main.cpp)
if(BUILD_btl_goto)
target_link_libraries(btl_goto ${GOTO_LIBRARIES} )
- set_target_properties(btl_goto PROPERTIES COMPILE_FLAGS "-DCBLASNAME=GOTO -DPUREBLAS")
+ set_target_properties(btl_goto PROPERTIES COMPILE_FLAGS "-DCBLASNAME=GOTO")
endif(BUILD_btl_goto)
endif (GOTO_FOUND)
find_package(GOTO2)
if (GOTO2_FOUND)
- include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
btl_add_bench(btl_goto2 main.cpp)
if(BUILD_btl_goto2)
target_link_libraries(btl_goto2 ${GOTO_LIBRARIES} )
- set_target_properties(btl_goto2 PROPERTIES COMPILE_FLAGS "-DCBLASNAME=GOTO2 -DPUREBLAS")
+ set_target_properties(btl_goto2 PROPERTIES COMPILE_FLAGS "-DCBLASNAME=GOTO2")
endif(BUILD_btl_goto2)
endif (GOTO2_FOUND)
find_package(ACML)
if (ACML_FOUND)
- include_directories(${PROJECT_SOURCE_DIR}/libs/f77)
btl_add_bench(btl_acml main.cpp)
if(BUILD_btl_acml)
target_link_libraries(btl_acml ${ACML_LIBRARIES} )
- set_target_properties(btl_acml PROPERTIES COMPILE_FLAGS "-DCBLASNAME=ACML -DHAS_LAPACK=1 -DPUREBLAS")
+ set_target_properties(btl_acml PROPERTIES COMPILE_FLAGS "-DCBLASNAME=ACML -DHAS_LAPACK=1")
endif(BUILD_btl_acml)
endif (ACML_FOUND)
+
+if(Eigen_SOURCE_DIR AND CMAKE_Fortran_COMPILER_WORKS)
+ # we are inside Eigen and blas/lapack interface is compilable
+ include_directories(${Eigen_SOURCE_DIR})
+ btl_add_bench(btl_eigenblas main.cpp)
+ if(BUILD_btl_eigenblas)
+ target_link_libraries(btl_eigenblas eigen_blas eigen_lapack )
+ set_target_properties(btl_eigenblas PROPERTIES COMPILE_FLAGS "-DCBLASNAME=EigenBLAS")
+ endif()
+endif()