aboutsummaryrefslogtreecommitdiffhomepage
path: root/bench/btl/data/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bench/btl/data/CMakeLists.txt')
-rw-r--r--bench/btl/data/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/bench/btl/data/CMakeLists.txt b/bench/btl/data/CMakeLists.txt
index 0057614da..daa65fed4 100644
--- a/bench/btl/data/CMakeLists.txt
+++ b/bench/btl/data/CMakeLists.txt
@@ -1,7 +1,7 @@
ADD_CUSTOM_TARGET(copy_scripts)
-SET(script_files go_mean aat.hh ata.hh axpy.hh order_lib mk_mean_script.sh mk_new_gnuplot.sh mk_gnuplot_script.sh matrix_matrix.hh matrix_vector.hh atv.hh)
+SET(script_files go_mean aat.hh ata.hh axpy.hh order_lib mk_mean_script.sh mk_new_gnuplot.sh mk_gnuplot_script.sh matrix_matrix.hh matrix_vector.hh atv.hh header.html footer.html perlib_plot_settings.txt gnuplot_common_settings.hh )
FOREACH(script_file ${script_files})
ADD_CUSTOM_COMMAND(
@@ -12,6 +12,19 @@ ADD_CUSTOM_COMMAND(
)
ENDFOREACH(script_file)
+ADD_CUSTOM_COMMAND(
+ TARGET copy_scripts
+ POST_BUILD
+ COMMAND ${CMAKE_CXX_COMPILER} --version | head -n 1 > ${CMAKE_CURRENT_BINARY_DIR}/compiler_version.txt
+ ARGS
+)
+ADD_CUSTOM_COMMAND(
+ TARGET copy_scripts
+ POST_BUILD
+ COMMAND echo "${Eigen_SOURCE_DIR}" > ${CMAKE_CURRENT_BINARY_DIR}/eigen_root_dir.txt
+ ARGS
+)
+
add_executable(smooth smooth.cxx)
add_executable(regularize regularize.cxx)
add_executable(main mean.cxx)