aboutsummaryrefslogtreecommitdiffhomepage
path: root/Eigen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Eigen/CMakeLists.txt')
-rw-r--r--Eigen/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/Eigen/CMakeLists.txt b/Eigen/CMakeLists.txt
index e0eb837a5..af90db2fe 100644
--- a/Eigen/CMakeLists.txt
+++ b/Eigen/CMakeLists.txt
@@ -1,7 +1,12 @@
-set(Eigen_HEADERS Core LU Cholesky QR Geometry Sparse Array SVD LeastSquares QtAlignedMalloc StdVector Householder Jacobi Eigenvalues)
+file(GLOB Eigen_directory_files "*")
+foreach(f ${Eigen_directory_files})
+ if(NOT f MATCHES ".txt" AND NOT f MATCHES "src")
+ list(APPEND Eigen_directory_files_to_install ${f})
+ endif()
+endforeach(f ${Eigen_directory_files})
install(FILES
- ${Eigen_HEADERS}
+ ${Eigen_directory_files_to_install}
DESTINATION ${INCLUDE_INSTALL_DIR}/Eigen COMPONENT Devel
)