aboutsummaryrefslogtreecommitdiffhomepage
path: root/Eigen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Eigen/CMakeLists.txt')
-rw-r--r--Eigen/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/Eigen/CMakeLists.txt b/Eigen/CMakeLists.txt
new file mode 100644
index 000000000..12c48c4a4
--- /dev/null
+++ b/Eigen/CMakeLists.txt
@@ -0,0 +1,14 @@
+FILE(GLOB Eigen_SRCS "*.h")
+
+SET(INCLUDE_INSTALL_DIR
+ "${CMAKE_INSTALL_PREFIX}/include/eigen2"
+ CACHE PATH
+ "The directory where we install the header files"
+ FORCE)
+
+INSTALL(FILES
+ ${Eigen_SRCS}
+ DESTINATION ${INCLUDE_INSTALL_DIR}
+ )
+
+add_subdirectory(Core) \ No newline at end of file