aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d5d855183..16f21faa5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,7 +88,11 @@ else()
set(CMAKE_BUILD_TYPE "Release")
endif()
-option(EIGEN_SPLIT_LARGE_TESTS "Split large tests into smaller executables" ON)
+if(cmake_generator_tolower MATCHES "makefile" AND NOT MSVC_IDE)
+ option(EIGEN_SPLIT_LARGE_TESTS "Split large tests into smaller executables" ON)
+else()
+ option(EIGEN_SPLIT_LARGE_TESTS "Split large tests into smaller executables" OFF)
+endif()
option(EIGEN_DEFAULT_TO_ROW_MAJOR "Use row-major as default matrix storage order" OFF)
if(EIGEN_DEFAULT_TO_ROW_MAJOR)