aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6f027cb44..8eee0a0eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -294,7 +294,11 @@ add_subdirectory(unsupported)
add_subdirectory(demos EXCLUDE_FROM_ALL)
-add_subdirectory(blas EXCLUDE_FROM_ALL)
+if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
+ add_subdirectory(blas)
+else()
+ add_subdirectory(blas EXCLUDE_FROM_ALL)
+endif()
# must be after test and unsupported, for configuring buildtests.in
add_subdirectory(scripts EXCLUDE_FROM_ALL)