aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 13 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 97397c0f6..90b969972 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,18 +1,18 @@
-project(Eigen)
+PROJECT(Eigen)
-OPTION(BUILD_TESTS "Build tests" OFF)
-OPTION(BUILD_EXAMPLES "Build examples" OFF)
+OPTION(BUILD_TESTS "Build tests" OFF)
+OPTION(BUILD_DOC "Build documentation and examples" OFF)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
+SET(CMAKE_INCLUDE_CURRENT_DIR ON)
-if(CMAKE_COMPILER_IS_GNUCXX)
- if (CMAKE_SYSTEM_NAME MATCHES Linux)
- set ( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -fno-exceptions -fno-check-new -fno-common -fstrict-aliasing")
- endif (CMAKE_SYSTEM_NAME MATCHES Linux)
-endif (CMAKE_COMPILER_IS_GNUCXX)
+IF(CMAKE_COMPILER_IS_GNUCXX)
+ IF(CMAKE_SYSTEM_NAME MATCHES Linux)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -fno-exceptions -fno-check-new -fno-common -fstrict-aliasing")
+ ENDIF(CMAKE_SYSTEM_NAME MATCHES Linux)
+ENDIF(CMAKE_COMPILER_IS_GNUCXX)
-include_directories( ${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} )
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR})
-add_subdirectory(Eigen)
-add_subdirectory(test)
-add_subdirectory(doc)
+ADD_SUBDIRECTORY(Eigen)
+ADD_SUBDIRECTORY(test)
+ADD_SUBDIRECTORY(doc)