aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-03-18 12:17:37 -0700
committerGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-03-18 12:17:37 -0700
commitbb0e73c1914c675755e8fab2a6db168b65a4de51 (patch)
treed65c32bb8c3e1cc61add5ba8e88480bf31807227 /unsupported/test/CMakeLists.txt
parent2db4a048278db4e07eefa2ae9ad4ce7254c9faec (diff)
Gate all the CUDA tests under the EIGEN_TEST_NVCC option
Diffstat (limited to 'unsupported/test/CMakeLists.txt')
-rw-r--r--unsupported/test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/unsupported/test/CMakeLists.txt b/unsupported/test/CMakeLists.txt
index 79c26fb72..19893cc25 100644
--- a/unsupported/test/CMakeLists.txt
+++ b/unsupported/test/CMakeLists.txt
@@ -174,7 +174,7 @@ endif()
# These tests needs nvcc
find_package(CUDA 7.0)
-if(CUDA_FOUND)
+if(CUDA_FOUND AND EIGEN_TEST_NVCC)
# Mke sure to compile without the -pedantic and -Wundef flags since they trigger thousands of compilation warnings in the CUDA runtime
string(REPLACE "-pedantic" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
string(REPLACE "-Wundef" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")