aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Christian Seiler <christian@iwakd.de>2013-11-14 22:27:06 +0100
committerGravatar Christian Seiler <christian@iwakd.de>2013-11-14 22:27:06 +0100
commit5e28c41549c5e71011bb9312104d1d30e919e53f (patch)
tree93b4e92e849993fb94512d628bdbb18e7401e3bf /unsupported/test/CMakeLists.txt
parente59b38abef4dec8e37037284760607d3e108958f (diff)
C++11: add template metaprogramming helpers
Create a new directory CXX11 under unsupported/Eigen that contains code that requires C++11. In that directory, add a few generic templates useful for any module relying on C++11. These templates may be included with #include <[unsupported/]Eigen/CXX11/Core>. At the moment, this will only provide templates in the Eigen::internal namespace.
Diffstat (limited to 'unsupported/test/CMakeLists.txt')
-rw-r--r--unsupported/test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/unsupported/test/CMakeLists.txt b/unsupported/test/CMakeLists.txt
index 38c89a234..841cab9d7 100644
--- a/unsupported/test/CMakeLists.txt
+++ b/unsupported/test/CMakeLists.txt
@@ -92,3 +92,11 @@ ei_add_test(gmres)
ei_add_test(minres)
ei_add_test(levenberg_marquardt)
ei_add_test(bdcsvd)
+
+option(EIGEN_TEST_CXX11 "Enable testing of C++11 features (e.g. Tensor module)." OFF)
+if(EIGEN_TEST_CXX11)
+ # FIXME: add C++11 compiler switch in some portable way
+ # (MSVC doesn't need any for example, so this will
+ # clash there)
+ ei_add_test(cxx11_meta "-std=c++0x")
+endif()