aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-10-07 11:04:16 -0700
committerGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-10-07 11:04:16 -0700
commit5c68051cd7941a83de4c9dcc18a437e4a800ed12 (patch)
treeb67f1cbab955c89c71ba580002c7f6b3675e5449 /unsupported/test/CMakeLists.txt
parentd485d12c51bc46286f7439377e3ab591f67ddbbf (diff)
parentd7f9679a34ef991fa3c9da8f61510d6c48aaa19c (diff)
Merge the content of the ComputeCpp branch into the default branch
Diffstat (limited to 'unsupported/test/CMakeLists.txt')
-rw-r--r--unsupported/test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/unsupported/test/CMakeLists.txt b/unsupported/test/CMakeLists.txt
index a1823beaa..17073dfa7 100644
--- a/unsupported/test/CMakeLists.txt
+++ b/unsupported/test/CMakeLists.txt
@@ -248,3 +248,11 @@ if(CUDA_FOUND AND EIGEN_TEST_CUDA)
unset(EIGEN_ADD_TEST_FILENAME_EXTENSION)
endif()
+
+
+if(EIGEN_TEST_SYCL)
+ ei_add_test_sycl(cxx11_tensor_sycl "-std=c++11")
+ ei_add_test_sycl(cxx11_tensor_forced_eval_sycl "-std=c++11")
+ ei_add_test_sycl(cxx11_tensor_broadcast_sycl "-std=c++11")
+ ei_add_test_sycl(cxx11_tensor_device_sycl "-std=c++11")
+endif(EIGEN_TEST_SYCL) \ No newline at end of file